What browsers and operating systems does Pluralsight Skills support?

Tags: Skills

To use Pluralsight Skills and watch Skills videos, we recommend using the following browsers and applications. Please be sure to be on the latest version of both your operating system and your browser:

  • Windows 8.1, 10, and 11; and macOS: 
    • Microsoft Edge 
    • Firefox
    • Chrome
    • Safari

We do not support:

  • Opera
  • Internet Explorer

Skills videos will work natively on Linux on a browser, since we stream videos through HTML5. Depending on your version of Linux, you might run into codec issues. The Pluralsight offline player does not work on Linux at this time.

Videos taking too long to load? See Troubleshooting video player issues.

To download our mobile, desktop, and TV apps, please visit our app downloads page. For additional help with our apps, see our Apps and offline viewing articles.

Looking for Pluralsight Flow requirements?

For recommended Flow Enterprise Server operating systems, please see the Flow Enterprise Server article.

For recommended Flow cloud browsers, please see the Flow cloud browser article.

back to top


If you need help, please email Support (opens email form) for 24/7 assistance.